fixing_antec_400w_supply

A friend of mine asked me take a look at his power supply, because suddenly it stopped working. Of course I said yes, and the first thing to check after I removed it’s top, was the fuse. The fuse was wrapped inside heat shrinking tube which made the checking a bit difficult. After peeling some of the shrinking tube I was able to measure it’s continuity and find out that it was blown. At that time I hoped this was the only problem, I replaced it and powered the supply, but my joy was short, because the new fuse was blown too.

Obviously the problem needed further investigation, so I went along and checked the rectifier bridge, which was ok. The capacitors looked ok, so the next thing I had to check was the two switching transistors. To do that I had to remove the hole radiator which contained more than the transistors. Checking the transistors gave me the answer to the problem, because I found both to be broken. But now a new problem was raised when trying to find replacements for the two transistors 2SC3320. I was only able to find these in stores across US and China and both of these places would make the shipping and tax costs to high to be worth buying from there.

fixing_antec_400w_supply

Now I have only two options, one is for someone to have a broken power source that has these same transistors, and that they’re still working, and the other is to find a replacement for these transistors, which I tried but with no luck. I wasn’t able to find another transistor to match it’s characteristics.

This is the datasheet of the 2SC3320 transistor. If you have any ideas on how I could solve this, please comment.